• 1分前

Flutter Null safety非対応のパッケージがあるとRunが通らない問題の対応

Flutter Null safety非対応のパッケージがあるとRunが通らない問題の対応についてのメモです。Flutterをバージョン2にあげた時やライブラリをpub getした時、対応してないパッケージをスルーする方法です。


Error: Cannot run with sound null safety, because the following dependencies
don't support null safety:


の様なエラーが出た時は

flutter run --no-sound-null-safety



とするとビルドが通る様になります。

Android studioの実行時の設定は
Run -> Edit Configurations -> Add Additional Run args -> --no-sound-null-safety


で設定できます。

VSCodeは

Debug ->Open Configuration ->launch.jsonの args


で設定すれば行けそうです。

yass

Flutter/Android/Nuxt/Django/Firebase/iOS

東京、武蔵野市にあるWebサイト制作、Webシステム開発、モバイルアプリ開発、システム設計、構築、ITコンサルティングを行なっている会社です。 開発会社、ベンチャー、フリーランスで10年以上フルスタックエンジニアとして開発してきた代表が理想とする開発基盤、システム運用手法、最新技術を取り入れ、受託開発や自社サービスの開発を行っています。

info@lorchestra.dev
042-266-2750(代表)